package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\S[^\S\n]*)$`)
var str = `non empty line
one more line`
var substitution = "$1 - added a word"
fmt.Println(re.ReplaceAllString(str, substitution))
}