use strict;
my $str = 'non empty line
one more line';
my $regex = qr/(\S[^\S\n]*)$/mp;
my $subst = '$1 - added a word';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";