# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\/\/.*|\/\*(?s:.*?)\*\/|("(?:(?<!\\)(?:\\\\)*\\"|[^\r\n"])*")/$1/g;t' <<< " String str1 = \"SUM 10\" /*This is a Comments */ ;
String str2 = \"SUM 10\"; //This is a Comments\"
String str3 = \"http://google.com\"; /*This is a Comments*/
String str4 = \"('file:///xghsghsh.html/')\"; //Comments
String str5 = \"{\\"temperature\\": {\\"type\\"}}\"; //comments
abc /*def
foo*/ bar
\"xxx\\"xxx\\\"
\"xxx\\\\"xxx\\\\\""