#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "//.*|/\*(?s:.*?)\*/|("(?:(?<!\\)(?:\\\\)*\\"|[^\r\n"])*")"
Local $sString = " String str1 = "SUM 10" /*This is a Comments */ ; " & @CRLF & _
" String str2 = "SUM 10"; //This is a Comments" " & @CRLF & _
" String str3 = "http://google.com"; /*This is a Comments*/" & @CRLF & _
" String str4 = "('file:///xghsghsh.html/')"; //Comments" & @CRLF & _
" String str5 = "{\"temperature\": {\"type\"}}"; //comments" & @CRLF & _
"abc /*def" & @CRLF & _
"foo*/ bar" & @CRLF & _
""xxx\"xxx\\"" & @CRLF & _
""xxx\\\"xxx\\\\""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)