$re = '@//.*|/\*(?s:.*?)\*/|("(?:(?<!\\\\)(?:\\\\\\\\)*\\\\"|[^\r\n"])*")@';
$str = ' String str1 = "SUM 10" /*This is a Comments */ ;
String str2 = "SUM 10"; //This is a Comments"
String str3 = "http://google.com"; /*This is a Comments*/
String str4 = "(\'file:///xghsghsh.html/\')"; //Comments
String str5 = "{\\"temperature\\": {\\"type\\"}}"; //comments
abc /*def
foo*/ bar
"xxx\\"xxx\\\\"
"xxx\\\\\\"xxx\\\\\\\\"';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;