using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"//.*|/\*(?s:.*?)\*/|(""(?:(?<!\\)(?:\\\\)*\\""|[^\r\n""])*"")";
string substitution = @"$1";
string input = @" String str1 = ""SUM 10"" /*This is a Comments */ ;
String str2 = ""SUM 10""; //This is a Comments""
String str3 = ""http://google.com""; /*This is a Comments*/
String str4 = ""('file:///xghsghsh.html/')""; //Comments
String str5 = ""{\""temperature\"": {\""type\""}}""; //comments
abc /*def
foo*/ bar
""xxx\""xxx\\""
""xxx\\\""xxx\\\\""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}