# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"//.*|/\*(?s:.*?)\*/|(\"(?:(?<!\\)(?:\\\\)*\\\"|[^\r\n\"])*\")"
test_str = (" String str1 = \"SUM 10\" /*This is a Comments */ ; \n"
" String str2 = \"SUM 10\"; //This is a Comments\" \n"
" String str3 = \"http://google.com\"; /*This is a Comments*/\n"
" String str4 = \"('file:///xghsghsh.html/')\"; //Comments\n"
" String str5 = \"{\\\"temperature\\\": {\\\"type\\\"}}\"; //comments\n"
"abc /*def\n"
"foo*/ bar\n"
"\"xxx\\\"xxx\\\\\"\n"
"\"xxx\\\\\\\"xxx\\\\\\\\\"")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.