const regex = new RegExp('//.*|/\\*(?s:.*?)\\*/|("(?:(?<!\\\\)(?:\\\\\\\\)*\\\\"|[^\\r\\n"])*")', 'g')
const str = ` String str1 = "SUM 10" /*This is a Comments */ ;
String str2 = "SUM 10"; //This is a Comments"
String str3 = "http://google.com"; /*This is a Comments*/
String str4 = "('file:///xghsghsh.html/')"; //Comments
String str5 = "{\\"temperature\\": {\\"type\\"}}"; //comments
abc /*def
foo*/ bar
"xxx\\"xxx\\\\"
"xxx\\\\\\"xxx\\\\\\\\"`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);