#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "000001(?!.*;000001;)"
Local $sString = "000001;000001;"
Local $sSubst = "00002"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)