const regex = /000001(?!.*;000001;)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('000001(?!.*;000001;)', '')
const str = `000001;000001;`;
const subst = `00002`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);