import re
regex = re.compile(r"000001(?!.*;000001;)")
test_str = "000001;000001;"
subst = "00002"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)