using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"000001(?!.*;000001;)";
string substitution = @"00002";
string input = @"000001;000001;";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}