#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([a-z])([A-Z])"
Local $sString = "Rooms available: Master bedroomDining roomLiving room"
Local $sSubst = "$1, $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)