use strict;
my $str = 'Rooms available: Master bedroomDining roomLiving room';
my $regex = qr/([a-z])([A-Z])/p;
my $subst = '$1, $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";