$re = '/([a-z])([A-Z])/';
$str = 'Rooms available: Master bedroomDining roomLiving room';
$subst = "$1, $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;