package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-z])([A-Z])`)
var str = `Rooms available: Master bedroomDining roomLiving room`
var substitution = "$1, $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}