import Foundation
let pattern = #"([a-z])([A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Rooms available: Master bedroomDining roomLiving room"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1, $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)