re = /([a-z])([A-Z])/
str = 'Rooms available: Master bedroomDining roomLiving room'
subst = '$1, $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result