#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-9]\d*|0)\.(\d*[1-9]+)$"
Local $sString = "小数点左侧条件1:[1-9]开头的数字后面可以是任何数量的数字" & @CRLF & _
"小数点左侧条件2:只有一个0" & @CRLF & _
"小数点右侧条件1:任意数量的数字,并且结尾必须是[1-9]" & @CRLF & _
"1" & @CRLF & _
"1." & @CRLF & _
"1.0" & @CRLF & _
"1.10" & @CRLF & _
"01.1" & @CRLF & _
"01.01" & @CRLF & _
"01.10" & @CRLF & _
"2.1" & @CRLF & _
"2.20" & @CRLF & _
"2.01" & @CRLF & _
"2.020" & @CRLF & _
"3.105" & @CRLF & _
"3.01205" & @CRLF & _
"2.005" & @CRLF & _
"0.02"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")