import Foundation
let pattern = #"^([1-9]\d*|0)\.(\d*[1-9]+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
小数点左侧条件1:[1-9]开头的数字后面可以是任何数量的数字
小数点左侧条件2:只有一个0
小数点右侧条件1:任意数量的数字,并且结尾必须是[1-9]
1
1.
1.0
1.10
01.1
01.01
01.10
2.1
2.20
2.01
2.020
3.105
3.01205
2.005
0.02
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)