re = /^([1-9]\d*|0)\.(\d*[1-9]+)$/m
str = '小数点左侧条件1:[1-9]开头的数字后面可以是任何数量的数字
小数点左侧条件2:只有一个0
小数点右侧条件1:任意数量的数字,并且结尾必须是[1-9]
1
1.
1.0
1.10
01.1
01.01
01.10
2.1
2.20
2.01
2.020
3.105
3.01205
2.005
0.02'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end