import re
regex = re.compile(r"^([1-9]\d*|0)\.(\d*[1-9]+)$", flags=re.MULTILINE)
test_str = ("小数点左侧条件1:[1-9]开头的数字后面可以是任何数量的数字\n"
"小数点左侧条件2:只有一个0\n"
"小数点右侧条件1:任意数量的数字,并且结尾必须是[1-9]\n"
"1\n"
"1.\n"
"1.0\n"
"1.10\n"
"01.1\n"
"01.01\n"
"01.10\n"
"2.1\n"
"2.20\n"
"2.01\n"
"2.020\n"
"3.105\n"
"3.01205\n"
"2.005\n"
"0.02")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")