use strict;
my $str = '小数点左侧条件1:[1-9]开头的数字后面可以是任何数量的数字
小数点左侧条件2:只有一个0
小数点右侧条件1:任意数量的数字,并且结尾必须是[1-9]
1
1.
1.0
1.10
01.1
01.01
01.10
2.1
2.20
2.01
2.020
3.105
3.01205
2.005
0.02';
my $regex = qr/^([1-9]\d*|0)\.(\d*[1-9]+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}