#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<li><a href=".*\.html" title=".*">.* (?:(?!\b(22|9|13|23|4|15)\b).)*<\/a><\/li>$"
Local $sString = "<li><a href="xxx.html" title="xxx">xxx (22)</a></li>" & @CRLF & _
"<li><a href="yyy.html" title="yyy">yyy (21)</a></li>" & @CRLF & _
"<li><a href="zzz.html" title="zzz">zzz (13)</a></li>" & @CRLF & _
"<li><a href="xxx.html" title="xxx">xxx (23)</a></li>" & @CRLF & _
"<li><a href="yyy.html" title="yyy">yyy (24)</a></li>" & @CRLF & _
"<li><a href="zzz.html" title="zzz">zzz (15)</a></li>" & @CRLF & _
"" & @CRLF & _
"These are default rows." & @CRLF & _
"" & @CRLF & _
"This is the search regex I need-it. Just found it !" & @CRLF & _
"" & @CRLF & _
"<li><a href=".*\.html" title=".*">.* (?:(?!\b(22|9|13|23|4|15)\b).)*<\/a><\/li>$" & @CRLF & _
"" & @CRLF & _
"So, the default numbers are in (). And in my regex I put two different numbers 9 and 4 insteaed of (21) and (24)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")