# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<li><a href=\".*\.html\" title=\".*\">.* (?:(?!\b(22|9|13|23|4|15)\b).)*<\/a><\/li>$"
test_str = ("<li><a href=\"xxx.html\" title=\"xxx\">xxx (22)</a></li>\n"
"<li><a href=\"yyy.html\" title=\"yyy\">yyy (21)</a></li>\n"
"<li><a href=\"zzz.html\" title=\"zzz\">zzz (13)</a></li>\n"
"<li><a href=\"xxx.html\" title=\"xxx\">xxx (23)</a></li>\n"
"<li><a href=\"yyy.html\" title=\"yyy\">yyy (24)</a></li>\n"
"<li><a href=\"zzz.html\" title=\"zzz\">zzz (15)</a></li>\n\n"
"These are default rows.\n\n"
"This is the search regex I need-it. Just found it !\n\n"
"<li><a href=\".*\\.html\" title=\".*\">.* (?:(?!\\b(22|9|13|23|4|15)\\b).)*<\\/a><\\/li>$\n\n"
"So, the default numbers are in (). And in my regex I put two different numbers 9 and 4 insteaed of (21) and (24)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.