const regex = /<li><a href=".*\.html" title=".*">.* (?:(?!\b(22|9|13|23|4|15)\b).)*<\/a><\/li>$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<li><a href=".*\\.html" title=".*">.* (?:(?!\\b(22|9|13|23|4|15)\\b).)*<\\\/a><\\\/li>$', 'gm')
const str = `<li><a href="xxx.html" title="xxx">xxx (22)</a></li>
<li><a href="yyy.html" title="yyy">yyy (21)</a></li>
<li><a href="zzz.html" title="zzz">zzz (13)</a></li>
<li><a href="xxx.html" title="xxx">xxx (23)</a></li>
<li><a href="yyy.html" title="yyy">yyy (24)</a></li>
<li><a href="zzz.html" title="zzz">zzz (15)</a></li>
These are default rows.
This is the search regex I need-it. Just found it !
<li><a href=".*\\.html" title=".*">.* (?:(?!\\b(22|9|13|23|4|15)\\b).)*<\\/a><\\/li>\$
So, the default numbers are in (). And in my regex I put two different numbers 9 and 4 insteaed of (21) and (24)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}