use strict;
my $str = '<li><a href="xxx.html" title="xxx">xxx (22)</a></li>
<li><a href="yyy.html" title="yyy">yyy (21)</a></li>
<li><a href="zzz.html" title="zzz">zzz (13)</a></li>
<li><a href="xxx.html" title="xxx">xxx (23)</a></li>
<li><a href="yyy.html" title="yyy">yyy (24)</a></li>
<li><a href="zzz.html" title="zzz">zzz (15)</a></li>
These are default rows.
This is the search regex I need-it. Just found it !
<li><a href=".*\\.html" title=".*">.* (?:(?!\\b(22|9|13|23|4|15)\\b).)*<\\/a><\\/li>$
So, the default numbers are in (). And in my regex I put two different numbers 9 and 4 insteaed of (21) and (24)';
my $regex = qr/<li><a href=".*\.html" title=".*">.* (?:(?!\b(22|9|13|23|4|15)\b).)*<\/a><\/li>$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}