using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<li><a href="".*\.html"" title="".*"">.* (?:(?!\b(22|9|13|23|4|15)\b).)*<\/a><\/li>$";
string input = @"<li><a href=""xxx.html"" title=""xxx"">xxx (22)</a></li>
<li><a href=""yyy.html"" title=""yyy"">yyy (21)</a></li>
<li><a href=""zzz.html"" title=""zzz"">zzz (13)</a></li>
<li><a href=""xxx.html"" title=""xxx"">xxx (23)</a></li>
<li><a href=""yyy.html"" title=""yyy"">yyy (24)</a></li>
<li><a href=""zzz.html"" title=""zzz"">zzz (15)</a></li>
These are default rows.
This is the search regex I need-it. Just found it !
<li><a href="".*\.html"" title="".*"">.* (?:(?!\b(22|9|13|23|4|15)\b).)*<\/a><\/li>$
So, the default numbers are in (). And in my regex I put two different numbers 9 and 4 insteaed of (21) and (24)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}