import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<li><a href=\".*\\.html\" title=\".*\">.* (?:(?!\\b(22|9|13|23|4|15)\\b).)*<\\/a><\\/li>$";
final String string = "<li><a href=\"xxx.html\" title=\"xxx\">xxx (22)</a></li>\n"
+ "<li><a href=\"yyy.html\" title=\"yyy\">yyy (21)</a></li>\n"
+ "<li><a href=\"zzz.html\" title=\"zzz\">zzz (13)</a></li>\n"
+ "<li><a href=\"xxx.html\" title=\"xxx\">xxx (23)</a></li>\n"
+ "<li><a href=\"yyy.html\" title=\"yyy\">yyy (24)</a></li>\n"
+ "<li><a href=\"zzz.html\" title=\"zzz\">zzz (15)</a></li>\n\n"
+ "These are default rows.\n\n"
+ "This is the search regex I need-it. Just found it !\n\n"
+ "<li><a href=\".*\\.html\" title=\".*\">.* (?:(?!\\b(22|9|13|23|4|15)\\b).)*<\\/a><\\/li>$\n\n"
+ "So, the default numbers are in (). And in my regex I put two different numbers 9 and 4 insteaed of (21) and (24)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}