#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[-+*\/]+|[-+*\/]+$|([-+*\/])[-+*\/]+"
Local $sString = "+58*/-47+-2*" & @CRLF & _
"++*46+8+*7+2*1" & @CRLF & _
"-9*-"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)