re = /^[-+*\/]+|[-+*\/]+$|([-+*\/])[-+*\/]+/m
str = '+58*/-47+-2*
++*46+8+*7+2*1
-9*-'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result