import re
regex = re.compile(r"^[-+*\/]+|[-+*\/]+$|([-+*\/])[-+*\/]+", flags=re.MULTILINE)
test_str = ("+58*/-47+-2*\n"
"++*46+8+*7+2*1\n"
"-9*-")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)