const regex = /^[-+*\/]+|[-+*\/]+$|([-+*\/])[-+*\/]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[-+*\\\/]+|[-+*\\\/]+$|([-+*\\\/])[-+*\\\/]+', 'gm')
const str = `+58*/-47+-2*
++*46+8+*7+2*1
-9*-`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);