package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[-+*\/]+|[-+*\/]+$|([-+*\/])[-+*\/]+`)
var str = `+58*/-47+-2*
++*46+8+*7+2*1
-9*-`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}