$re = '/^[-+*\/]+|[-+*\/]+$|([-+*\/])[-+*\/]+/m';
$str = '+58*/-47+-2*
++*46+8+*7+2*1
-9*-';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;