#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*)(_.*?)$"
Local $sString = "alpha123_4rf_Joe" & @CRLF & _
"45beta_Frank" & @CRLF & _
"Red5Great_Sam_Fun"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)