const regex = /^(.*)(_.*?)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*)(_.*?)$', 'mg')
const str = `alpha123_4rf_Joe
45beta_Frank
Red5Great_Sam_Fun`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);