using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*)(_.*?)$";
string substitution = @"\1";
string input = @"alpha123_4rf_Joe
45beta_Frank
Red5Great_Sam_Fun";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}