use strict;
my $str = 'alpha123_4rf_Joe
45beta_Frank
Red5Great_Sam_Fun';
my $regex = qr/^(.*)(_.*?)$/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";