$re = '/^(.*)(_.*?)$/m';
$str = 'alpha123_4rf_Joe
45beta_Frank
Red5Great_Sam_Fun';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;