package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(([^\)]+)\)`)
var str = `Der Hund wurde am 01.01.2016 geboren (AB)<br>
Am 05.06.2014 wurde ein anderer Hund geboren (XY) <br>
01.01.2016 ist der Tag der Tage, es war Neujahr (SI)<br>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}