$re = '/\(([^\)]+)\)/';
$str = 'Der Hund wurde am 01.01.2016 geboren (AB)<br>
Am 05.06.2014 wurde ein anderer Hund geboren (XY) <br>
01.01.2016 ist der Tag der Tage, es war Neujahr (SI)<br>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);