use strict;
my $str = 'Der Hund wurde am 01.01.2016 geboren (AB)<br>
Am 05.06.2014 wurde ein anderer Hund geboren (XY) <br>
01.01.2016 ist der Tag der Tage, es war Neujahr (SI)<br>';
my $regex = qr/\(([^\)]+)\)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}