re = /\(([^\)]+)\)/
str = 'Der Hund wurde am 01.01.2016 geboren (AB)<br>
Am 05.06.2014 wurde ein anderer Hund geboren (XY) <br>
01.01.2016 ist der Tag der Tage, es war Neujahr (SI)<br>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end