# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-z])_(?=[a-z])/\1'/gm;t' <<< "asdfasd a_b dsfd"