#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([a-z])_(?=[a-z])"
Local $sString = "asdfasd a_b dsfd"
Local $sSubst = "\1'"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)