use strict;
my $str = 'asdfasd a_b dsfd';
my $regex = qr/([a-z])_(?=[a-z])/mp;
my $subst = '\\1\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";