$re = '/([a-z])_(?=[a-z])/m';
$str = 'asdfasd a_b dsfd';
$subst = "\1'";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;