import re
regex = re.compile(r"([a-z])_(?=[a-z])", flags=re.MULTILINE)
test_str = "asdfasd a_b dsfd"
subst = "\\1'"
result = regex.sub(subst, test_str)
if result:
print(result)