import Foundation
let pattern = #"([a-z])_(?=[a-z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"asdfasd a_b dsfd"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1'"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)